What PHP version does the plugin require?

As for the PHP version, we strongly recommend using the last stable PHP and MySQL builds.

For more details regarding Plugin Requirements, refer to the link.