WP Travel plugin, like other software, has specific plugin requirements to work properly. In order to use WP Travel plugins without facing any problems, the following requirements must be fulfilled:

Note: We recommend you to use the latest version of everything on your site i.e. WordPress, themes, plugins for a better experience.

WordPress version:

WP Travel plugin’s latest version supports the WordPress version above v5.4.1.

PHP version:

To use the WP Travel plugin without any problem you should use the PHP version 5.6 or higher.

Note: We recommend you to use PHP Version 7.4 or above.

Database management systems:

WP Travel plugin requires MySQL to be version 5.7.33 or higher.

Browser requirements:

WP Travel plugins can be used in the following browsers:

The latest version of: 

  • Google Chrome for Android 
  • Samsung browser

The last two versions of:

  • Google Chrome
  • Firefox 
  • Safari
  • Edge
  • Opera

If you liked this article, then please subscribe to our YouTube Channel for WordPress video tutorials. You can also find us on Twitter and Facebook.

Further, if you have any queries, please submit them to our Contact page.