Current version of WP Travel Utilities requires atleast WP Travel Version 1.8.9.

  • The forum ‘WP Travel Utilities’ is closed to new topics and replies.