Error with Settings on Pro

Homepage Forums WP Travel Pro Error with Settings on Pro

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  Support Team 3 weeks, 2 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17233

    u12mjw@gmail.com
    Participant

    Hi

    Upgraded to WP Pro and the settings menu doesnt work and causes a fatal error which i have pasted below.

    Is this something I or you can fix?

    Thanks

    An error of type E_ERROR was caused in line 510 of the file /home/hebride1/public_html/startour/wp-content/plugins/wp-travel-pro/inc/modules/mailchimp-core/inc/api/class-wp-travel-mailchimp-api.php. Error message: Uncaught Error: Call to undefined function curl_init() in /home/hebride1/public_html/startour/wp-content/plugins/wp-travel-pro/inc/modules/mailchimp-core/inc/api/class-wp-travel-mailchimp-api.php:510
    Stack trace:
    #0 /home/hebride1/public_html/startour/wp-content/plugins/wp-travel-pro/inc/modules/mailchimp-core/inc/api/class-wp-travel-mailchimp-api.php(313): WP_Travel_MailChimp_Api->get(‘lists’, Array)
    #1 /home/hebride1/public_html/startour/wp-content/plugins/wp-travel-pro/inc/modules/mailchimp-core/inc/wp-travel-mailchimp-settings.php(38): WP_Travel_MailChimp_Api->getLists(true)
    #2 /home/hebride1/public_html/startour/wp-content/plugins/wp-travel-pro/inc/modules/mailchimp-core/inc/wp-travel-mailchimp-settings.php(67): wp_travel_mailchimp_settings->get_mc_lists()
    #3 /home/hebride1/public_html/startour/wp-includes/class-wp-hook.php(286): wp_travel_mailchimp_settings->add_settings(‘misc_options_gl…’, Array)
    #4 /home/hebride1/public_html/startour/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, A

    #17241

    Support Team
    Keymaster

    Hello,

    We would like to apologize for the trouble.

    The issue has raised because your server has not enabled the curl function.

    So please once request the server to enable the curl function.

    Also, we will fix the issue from our side as well and release the update soon.

    Thank you.

    #17246

    u12mjw@gmail.com
    Participant

    Hi thanks for your response. I am not technically smart so are you able to help me understand how I would request the server enable the curl function?

    Thank you

    #17252

    u12mjw@gmail.com
    Participant

    I should add Im a bluehost hosted wordpress user so not a server under my control. Tried to find the php.ini file in file manager but no sign anywhere!

    #17253

    u12mjw@gmail.com
    Participant

    Hi there.
    Thanks for your help – I have now resolved the issue by asking Bluehost for help and they enabled cURL.

    Appreciate you pointing me in the right direction.

    Thanks

    #17255

    Support Team
    Keymaster

    Hello,

    Glad we could help you.

    Also, we will fix the issue in our side as well so that these kinds of issue will not occur in the future.

    If you have any confusion further then kindly let us know.

    Also, we would really appreciate if could drop your valuable comments about the plugin and the support by following the link below:

    https://wordpress.org/support/plugin/wp-travel/reviews/

    Thank you.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.