**URGENT** 2.0.4 Update Removed ALL plugin functionality on trip page

Homepage Forums WP Travel **URGENT** 2.0.4 Update Removed ALL plugin functionality on trip page

This topic contains 4 replies, has 3 voices, and was last updated by  Support Team 5 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16708

    MountainTraveler
    Participant

    Hey Support team:

    I just updated the plugin to 2.0.4 along with WP Utilities 1.2.9 and the entire functionality of the plugin on the frontend for the trip pages disappeared. Blank page…no content other than header and footer.

    Running Travel Base Pro.

    This is theme and plugin eco-system are a subdomain running on the same hosting account as the primary domain. I cross-checked the site health function under Tools. The primary domain has no problems, but this subdomain is displaying the following:

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API request failed due to an error.
    Error: [] cURL error 28: Operation timed out after 10002 milliseconds with 0 bytes received

    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.

    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error: [] cURL error 28: Operation timed out after 10003 milliseconds with 0 bytes received

    This was not happening before the update. Can we roll out a quick solution?

    #16709

    MountainTraveler
    Participant

    Hey Support:

    I had to roll back to a previous version via a backup made by my host. Once I restored to WP Travel 2.0.3 and Utilities 1.2.8 site is working as it should be.

    Your team will definitely want to look into this ASAP.

    Thanks!

    #16712

    Support Team
    Keymaster

    Hello @infosanooktiew-com,

    We would like to apologize for the trouble.

    The issue is related to the theme but not the plugin.

    The issue was in the older versions, version less than 1.0.5 but now the issue has been fixed in the recent version of the theme which is (1.0.5). The plugin only worked perfectly with the recent version since we have fixed the issue in the recent version of the theme.

    So please once update to the recent version and verify the issue.

    If the issue still persists even with the latest version of the theme then kindly let us know.

    Thank you.

    #16754

    alex
    Participant

    I don’t have the theme activated and 2.0.4 also broke itinerary pages : No more tabs.
    2.0.5 doesn’t seem to fix the issue
    Rolling back to 2.0.3 is fixing the issue

    #16791

    Support Team
    Keymaster

    Hello @alex,

    first of all, we would like to apologize for the trouble.

    Recently i.e. with version 2.0.4, we have deprecated some of the function so that might have raised the issue.

    So you need to update those hook and you can find the list of the hooks in the link below:
    https://wptravel.io/documentations/user-documentation/#doc-wp-travel-deprecated-hooks-76

    Also, please mention the theme that you have used so that we can check the issue from our side as well.

    Please provide your site URL as well.

    Thank you.

    Regards!!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.