WP-Travel v 1.4.8 results in fatal error when activated

Homepage Forums WP Travel WP-Travel v 1.4.8 results in fatal error when activated

Tagged: 

This topic contains 5 replies, has 3 voices, and was last updated by  Support Team 2 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7503

    passang
    Participant

    I updated the plugin from 1.2.5 to the current version (1.4.8) on WordPress 4.9.7 and I got this error: Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home1/ywyna0ep/public_html/wp-content/plugins/wp-travel/inc/coupon/inc/admin/class-admin-metaboxes.php on line 23

    I reinstalled the plugin but I’m not able to activate the plugin due to the aforementioned error:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home1/ywyna0ep/public_html/wp-content/plugins/wp-travel/inc/coupon/inc/admin/class-admin-metaboxes.php on line 23

    How can I resolve this problem? Thank you.

    #7504

    Support Team
    Keymaster

    Hello @passang,

    Thank you very much for using the PE travel plugin and also we would like to apologize for the trouble.

    To find what might have actually caused the issue please refer to below given link:

    http://wptravel.io/parse-error/

    Hope this helps.

    If you have any confusion further then please let us know.

    Thank you.

    Best Regards!!

    #7506

    passang
    Participant

    The version I have is PHP 7.1. Is WP-Travel 1.4.8 compatible with PHP 7.1?

    #7512

    Support Team
    Keymaster

    Hello @passang,

    The WP Travel plugin latest version (1.4.8) is very much compatible with the PHP 7.1 version.

    So please once verify properly whether your server has above mentioned PHP version or not?

    Also, please provide your system information for the further inspection which you can find by clicking on the System Information link available on the Trips > Setting page.

    Screenshot:

    https://prnt.sc/k7tmh6

    Thank you.

    Regards!!

    #16627

    MountainTraveler
    Participant

    Hey Support team:

    My host, Siteground, indicated that WP Travel Plugin has a conflict with PHP 7.1, and therefore I cannot implement 7.1.

    Has something possibly changed since this thread was originally posted?

    #16629

    Support Team
    Keymaster

    Hello @infosanooktiew-com,

    When tested the WP Travel plugin in the 7.1 PHP version, we could not find any issue. The plugin works perfectly fine.

    We also did test other add-ons as well in the very PHP version and did not find any issue.

    So can you please specify precisely what kind of compatibility issue if found by the server so that we can help you further?

    Also please post your queries by creating a separate topic as it will be easy for us to track your issues.

    Hoping to hear from you soon.

    Thank you.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.