WP Travel Field Editor version 1.0.1 is out now with some minor issue fixes.

If you spot any issues or face any problem using the addon, please report them to us in detail on our support page so that our development team can fix it and help you as soon as possible.

http://wptravel.io/support-forum/forum/wp-travel-field-editor/

Change Log

* Minor issue fixes.

Note : WP Travel Field editor version 1.0.1 requires at least version 1.8.9 of WP Travel Plugin.